On 03/02/2021 11:51, Philippe Mathieu-Daudé wrote:
In order to use inclusive terminology, rename pci_xbox_blacklisted() as pci_xbox_denylisted().
Signed-off-by: Philippe Mathieu-Daudé philmd@redhat.com
drivers/pci.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/pci.c b/drivers/pci.c index 34ae69a..19b9027 100644 --- a/drivers/pci.c +++ b/drivers/pci.c @@ -1356,7 +1356,7 @@ static void ob_pci_add_properties(phandle_t phandle, }
#ifdef CONFIG_XBOX -static char pci_xbox_blacklisted (int bus, int devnum, int fn) +static char pci_xbox_denylisted (int bus, int devnum, int fn) { /* * The Xbox MCPX chipset is a derivative of the nForce 1 @@ -1388,7 +1388,7 @@ static char pci_xbox_blacklisted (int bus, int devnum, int fn) return 1;
/*
* The device is not blacklisted.
*/ return 0; }* The device is not denylisted.
@@ -1708,7 +1708,7 @@ static int ob_pci_read_identification(int bus, int devnum, int fn, pci_addr addr;
#ifdef CONFIG_XBOX
- if (pci_xbox_blacklisted (bus, devnum, fn))
- if (pci_xbox_denylisted (bus, devnum, fn)) return; #endif addr = PCI_ADDR(bus, devnum, fn);
As a native English speaker "denylist" doesn't quite make sense in this context. Would renaming the function to pci_xbox_skip_device() and removing the comment completely work for you?
ATB,
Mark.