[SeaBIOS] WfW setup and DOS display.sys hanging

Kevin O'Connor kevin at koconnor.net
Wed Feb 5 23:39:52 CET 2014

On Wed, Feb 05, 2014 at 09:57:06PM +0100, Sebastian wrote:
> >>I can't reproduce the hang with the dosidle program linked by
> >>Sebastian.  (I ran the program on freedos and on an msdos floppy and
> >>both times it said it install succesfully.)  Can someone walk through
> >>the steps needed to reproduce the problem?
> >
> >I found some old Win3.1 images, and I do see the failure running setup
> >on that (when run from dos 6).  I'll look into it.
> >
> >Sebastian, can you document the steps to reproduce the dosidle and
> >display.sys failure?  (I tried putting display.sys into a dos6
> >config.sys, but it doesn't like my parameters so I don't think it's
> >doing anything.)
> I cloned the git repository, and built with:
> $ ./configure --target-list=i386-softmmu
> $ make -j2
> I then installed MS-DOS onto a virtual 50 MB disk, all default settings:
> $ /tmp/qemu/i386-softmmu/qemu-system-i386 -m 4 -hda msdos.img -fda
> After rebooting, qemu hangs with 100% cpu usage when loading
> DISPLAY.SYS. It is loaded by the following line in CONFIG.SYS:

Thanks.  That DEVICE line causes a failure for me as well and the call
trace is much easier to understand.

The SeaVGABIOS patch below fixes both the DISPLAY.SYS and Win3 setup
issue for me.  (I can't reproduce the dosidle problem.)


--- a/vgasrc/vgabios.c
+++ b/vgasrc/vgabios.c
@@ -1114,7 +1114,7 @@ struct funcInfo {
     u8 save_flags;
     u8 disp_info;
     u8 reserved_34[12];
 static void
 handle_101b(struct bregs *regs)

More information about the SeaBIOS mailing list