[SeaBIOS] WfW setup and DOS display.sys hanging

Sebastian basti at sraa.de
Wed Feb 5 21:57:06 CET 2014


>> I can't reproduce the hang with the dosidle program linked by
>> Sebastian.  (I ran the program on freedos and on an msdos floppy and
>> both times it said it install succesfully.)  Can someone walk through
>> the steps needed to reproduce the problem?
> I found some old Win3.1 images, and I do see the failure running setup
> on that (when run from dos 6).  I'll look into it.
> Sebastian, can you document the steps to reproduce the dosidle and
> display.sys failure?  (I tried putting display.sys into a dos6
> config.sys, but it doesn't like my parameters so I don't think it's
> doing anything.)

I cloned the git repository, and built with:
$ ./configure --target-list=i386-softmmu
$ make -j2

I then installed MS-DOS onto a virtual 50 MB disk, all default settings:
$ /tmp/qemu/i386-softmmu/qemu-system-i386 -m 4 -hda msdos.img -fda 

After rebooting, qemu hangs with 100% cpu usage when loading 
DISPLAY.SYS. It is loaded by the following line in CONFIG.SYS:


Surprisingly, this hang occurs with all of MS-DOS 5.00, 6.20 and 6.22 
(German), but not with a Russian MS-DOS 6.22 (which appears in english). 
I don't have any other language version of DOS to test with, though.

Best Regards,

More information about the SeaBIOS mailing list