[OpenBIOS] SPARC32: Trying to increase machine memory and failing

Artyom Tarasenko atar4qemu at gmail.com
Tue Oct 26 11:41:34 CEST 2010

On Tue, Oct 26, 2010 at 10:46 AM, Mark Cave-Ayland
<mark.cave-ayland at siriusit.co.uk> wrote:
> Andreas Färber wrote:
>> I think you need to adjust VMEM_SIZE in arch/sparc32/ldscript
>> accordingly...
>> Andreas
> I've just tried that, and still no dice starting qemu with the new ROM:
> ./qemu-system-sparc -cdrom /home/build/src/qemu/sparcimage/sol8-cd1.iso
> -boot d -nographic
> rom: requested regions overlap (rom
> /home/build/rel-qemu-git/share/qemu/openbios-sparc32.
> free=0x0000000070107000, addr=0x0000000070000000)
> rom loading failed
> Does this error mean that the ROMs are larger than the memory space
> allocated to them? Given that the SPARC32 ROM appears to load at 0xffd00000,
> surely that means the ROM can be a couple of MB without any problem?

Currently not a couple. hw/sun4m.c:

#define PROM_SIZE_MAX        (1024 * 1024)

> Currently the size on disk of the unstripped ROM is around 540KB which
> should be fine.

Yes, should be fine. But looks like you are hitting 512KiB limit somewhere...

Artyom Tarasenko

solaris/sparc under qemu blog: http://tyom.blogspot.com/

More information about the OpenBIOS mailing list