[OpenBIOS] SPARC32: Trying to increase machine memory and failing

Mark Cave-Ayland mark.cave-ayland at siriusit.co.uk
Tue Oct 26 10:46:06 CEST 2010

Andreas Färber wrote:

> I think you need to adjust VMEM_SIZE in arch/sparc32/ldscript 
> accordingly...
> Andreas

I've just tried that, and still no dice starting qemu with the new ROM:

./qemu-system-sparc -cdrom /home/build/src/qemu/sparcimage/sol8-cd1.iso 
-boot d -nographic
rom: requested regions overlap (rom 
free=0x0000000070107000, addr=0x0000000070000000)
rom loading failed

Does this error mean that the ROMs are larger than the memory space 
allocated to them? Given that the SPARC32 ROM appears to load at 
0xffd00000, surely that means the ROM can be a couple of MB without any 
problem? Currently the size on disk of the unstripped ROM is around 
540KB which should be fine.



Mark Cave-Ayland - Senior Technical Architect
PostgreSQL - PostGIS
Sirius Corporation plc - control through freedom
t: +44 870 608 0063

Sirius Labs: http://www.siriusit.co.uk/labs

More information about the OpenBIOS mailing list