[flashrom] Flashrom - DOS version report

Carl-Daniel Hailfinger c-d.hailfinger.devel.2006 at gmx.net
Fri Mar 19 04:50:48 CET 2010

Hi RayeR,

thanks for your report.

On 17.03.2010 10:14, RayeR wrote:
> I tried DOS version of flashrom and have some notes.
> First I tried it at work on a Dell PC with ATI SB600
> chipset but it failed to read flash.

That is very strange. Do you have a log? SB600 should work fine. Maybe
the SPI chip is not attached to the SB600 but instead to the SuperI/O.
Can you try
flashrom -p it87spi

> Then I tried at home on P31/ICH7 board and works fine,
> here'e listing of flash process:
> This chipset supports the following protocols: SPI.
> Calibrating delay loop... OK.
> Found chip "Winbond W25x40" (512 KB, SPI) at physical address 0xfff80000.
> This flash part has status UNTESTED for operations: ERASE           
> Please email a report to flashrom at flashrom.org if any of the above
> operations    work correctly for you with this flash part. Please
> include the flashrom    output with the additional -V option for all
> operations you tested (-V, -rV,    -wV, -EV), and mention which
> mainboard or programmer you tested. Thanks for your
> help!
> Flash image seems to be a legacy BIOS. Disabling checks.
> Writing flash chip...
> Erasing flash before programming... Erasing flash chip...
> spi_block_erase_20 failed during command execution at address 0x0
> done.
> Programming page:
> Verifying flash... VERIFIED.
> It flashed OK but why it displays this?
> spi_block_erase_20 failed during command execution at address 0x0

The W25x40 supports multiple erase commands, and your chipset does not
allow flashrom to use the spi_block_erase_20 command. Flashrom notices
that this command failed and tries another erase command which works.

> Then I looked with trace tool that flashrom makes some
> strange file operations, see log in attachment.

Yes, strange. Maybe that happens as side effect from DJGPP compilation?

> I found it tries to open dmidecode.exe I had it in PATH but when
> not flashrom hanged for some seconds and displays
> Bad command or filename about 6 times.

It should try only 2 times. If it tries more often, we have to check the
code (bug?). I think Rudolf(?) said that there are problems if we try to
run a CWSDPMI app (dmidecode) from another CWSDPMI app (flashrom).
Does it work if dmidecode.exe is in the PATH?
Hm. DMIDECODE.EXE is a name with 9+3 letters. That can't work on old DOS.

> Superiotool works on my ITE chip OK. BTW I UPXed it from ~2MB to 80kB :)



"I do consider assignment statements and pointer variables to be among
computer science's most valuable treasures."
-- Donald E. Knuth

More information about the flashrom mailing list