[flashrom] Flashrom - DOS version report

RayeR rayer at seznam.cz
Wed Mar 17 10:14:06 CET 2010

I tried DOS version of flashrom and have some notes.
First I tried it at work on a Dell PC with ATI SB600
chipset but it failed to read flash.

Then I tried at home on P31/ICH7 board and works fine,
here'e listing of flash process:

/This chipset supports the following protocols: SPI.            128,040
Calibrating delay loop... OK.                            
Found chip "Winbond W25x40" (512 KB, SPI) at physical address 
This flash part has status UNTESTED for operations: ERASE            
Please email a report to flashrom at flashrom.org if any of the above 
work correctly for you with this flash part. Please include the flashrom    
output with the additional -V option for all operations you tested (-V, 
-wV, -EV), and mention which mainboard or programmer you tested. Thanks 
for your
Flash image seems to be a legacy BIOS. Disabling checks.            
Writing flash chip... Erasing flash before programming... Erasing flash 
spi_block_erase_20 failed during command execution at address 0x0        
Programming page:                                
Verifying flash... VERIFIED.

/It flashed OK but why it displays this?
spi_block_erase_20 failed during command execution at address 0x0

Then I looked with trace tool that flashrom makes some
strange file operations, see log in attachment.

I found it tries to open dmidecode.exe I had it in PATH but when
not flashrom hanged for some seconds and displays
Bad command or filename about 6 times.

Superiotool works on my ITE chip OK. BTW I UPXed it from ~2MB to 80kB :)

-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: flashrom.log
URL: <http://www.flashrom.org/pipermail/flashrom/attachments/20100317/ebb698c7/attachment.log>

More information about the flashrom mailing list