[coreboot] Questions about using coreboot riscv with qemu

Liam Naddell liamnprg at gmail.com
Mon Sep 10 16:03:14 CEST 2018

This is my first time using a mailing list btw, sorry.

I was wondering how I could test the images I have built with `make 
riscv-crossgcc && make` using qemu.

I tried running qemu-system-riscv64(the one gotten from the riscv-linux 
port), with the name of the image produced(coreboot.rom), and it did 

qemu-system-riscv64 ./build/coreboot.rom

qemu-system-riscv64: Trying to execute code outside RAM or ROM at 
This usually means one of the following happened:
(1) You told QEMU to execute a kernel for the wrong machine type, and it 
crashed on startup (eg trying to run a raspberry pi kernel on a 
versatilepb QEMU machine)
(2) You didn't give QEMU a kernel or BIOS filename at all, and QEMU 
executed a ROM full of no-op instructions until it fell off the end
(3) Your guest kernel has a bug and crashed by jumping off into nowhere
This is almost always one of the first two, so check your command line 
and that you are using the right type of kernel for this machine.
If you think option (3) is likely then you can try debugging your guest 
with the -d debug options; in particular -d guest_errors will cause the 
log to include a dump of the guest register state at this point.
Execution cannot continue; stopping here.

I also tried this using the -bios flag, and by using the make-spike-elf 
script with the -bios flag, and I still got nothing.

It would be really nice if somebody could help me :).

More information about the coreboot mailing list