[coreboot] F2A85-M: Memory issues

Martin Roth gaumless at gmail.com
Mon Apr 18 05:54:14 CEST 2016

Hi Daniel, unless you're using the memtest from the coreboot codebase, the
memtest failures are likely false.

Try this one - it should work better under SeaBIOS:
git clone https://review.coreboot.org/memtest86plus

You can also just build it into the coreboot image as a secondary payload
in the payloads menu of kconfig if you have an up-to-date version of

In general, AMD specified that you should populate the dimms from the
furthest away from the cpu to the closest. The vendor might have found that
it worked fine on this board, so changed their bios to remove that
restriction. I don't know if that's the issue you're seeing, but it's

I'll test it when I get a chance.

Thanks for the report.

On Sun, Apr 17, 2016 at 19:52 Daniel Kulesz via coreboot <
coreboot at coreboot.org> wrote:

> Hi folks,
> I just flashed Coreboot 4.3 release on my F2A85-M (the "original", not Pro
> or whatever) together with Seabios and the VGA ROM. I am running the "bare"
> board with an AMD A4-5700 APU and two 8GB Corsair Sticks () at 1,5V.  No
> attached peripherals except an usb stick which I use for booting a live
> system. Unfortunately, I experienced the following issues:
> (1) When I plug the memory sticks in the black DIMMs I get no Video,
> although they were working fine there before with the vendor bios. However,
> they "work" when inserted in the blue slots.
> (2) I am getting errors im memtest86+ 5.01 in compatibility mode in mem
> adresses around 3700M. I tried both sticks, each also in single
> configuration but the issue persists. I had no issues with the vendor bios
> (when inserted in the other slots).
> (3) The CPU temperature is reported wrong in Memtest86+ (Memtest86+
> reports 15°C while it was around 35-40°C in the vendor bios at around the
> same fan speed and environment conditions). However, I don't remember if it
> reported a correct value with the vendor bios.
> The memory sticks have been reported as follows by the vendor bios:
> Handle 0x0035, DMI type 17, 34 bytes
> Memory Device
>         Array Handle: 0x002F
>         Error Information Handle: Not Provided
>         Total Width: 64 bits
>         Data Width: 64 bits
>         Size: 4096 MB
>         Form Factor: DIMM
>         Set: None
>         Locator: DIMM_B1
>         Bank Locator: A1_BANK2
>         Type: DDR3
>         Type Detail: Synchronous Unbuffered (Unregistered)
>         Speed: 1333 MHz
>         Manufacturer: Corsair
>         Serial Number: 00000000
>         Asset Tag: A1_AssetTagNum2
>         Part Number: CMZ4GX3M1A1600C9
>         Rank: 2
>         Configured Clock Speed: 1333 MHz
> Are these known issues? Or maybe just a false alarm?
> Cheers, Daniel
> --
> coreboot mailing list: coreboot at coreboot.org
> https://www.coreboot.org/mailman/listinfo/coreboot
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20160418/452e1996/attachment-0001.html>

More information about the coreboot mailing list