[coreboot] booting fails on FAM10 machine

Maximilian Thuermer Maximilian.Thuermer at ziti.uni-heidelberg.de
Thu Oct 22 10:35:58 CEST 2009

Hi all,

I did a fresh svn co the other day and tried building and
running a Tyan S2912_fam10 system. With older sources
(rev 4729) everything worked just fine, with the newest checkout
the booting process stops at setting MTRR registers or a little
later (depending on the compiler used: 3.4.6 builds faster code
and gets further than 4.3.3, both Ubuntu fashion).
I tried tracking down the problem and it appeared to me as if
must have something to do with this though I couldnt find an
error when comparing all the files affected by this switch.
Attached are the last lines of the debug printout.
Does anyone have an idea, where this error might come from
or if there are any unintended side effects associated with this change?

Thanks in advance,


Maximilian Thuermer
 University of Heidelberg
 Zentrales Institut für Technische Informatik (ziti)
 Computer Architecture Group
 B 6, 26, 68131 Mannheim
 email: maximilian.thuermer at ziti.uni-heidelberg.de

-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: attach.txt
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20091022/0e050b60/attachment.txt>

More information about the coreboot mailing list