[coreboot] booting fails on FAM10 machine

Myles Watson mylesgw at gmail.com
Thu Oct 22 17:37:23 CEST 2009

> I did a fresh svn co the other day and tried building and
> running a Tyan S2912_fam10 system. With older sources
> (rev 4729) everything worked just fine, with the newest checkout
> the booting process stops at setting MTRR registers or a little
> later (depending on the compiler used: 3.4.6 builds faster code
> and gets further than 4.3.3, both Ubuntu fashion).
> I tried tracking down the problem and it appeared to me as if
It's possible.  Could you try Rev 4787 & 4788 to make sure, then send me the
logs from both?  I'm also interested in the coreboot_ram.map files.

> must have something to do with this though I couldnt find an
> error when comparing all the files affected by this switch.
> Attached are the last lines of the debug printout.
> Does anyone have an idea, where this error might come from
> or if there are any unintended side effects associated with this change?
There shouldn't have been any.  Hopefully everywhere it was (TOPK) it is now
(RAMTOP >> 10) and everywhere it was (TOPK<<10) it is (RAMTOP).

Thanks for helping track it down.


More information about the coreboot mailing list