[LinuxBIOS] Via epia-m2 difficulties

Peter Stuge stuge-linuxbios at cdy.org
Thu Nov 9 18:37:08 CET 2006

On Thu, Nov 09, 2006 at 03:42:20PM +0100, Kurt André Selbach wrote:
> Hi!
> I'm trying to get a working linuxbios on my Via epia m2 12000,
> with 1200mhz processor and 512mb ram.
> The goal is to boot linux from a usbstick (guess i will be using
> filo and boot the device a uda1)

Yep. I haven't tried that on my board, but from IDE works just fine.

> I've managed to extract my videobios image with awardeco and that
> gave me a videobios file which was exactly 57344byte, how can i
> apply this to my linuxbios.rom file?

Hm, this may not be the correct image. I'd suggest dumping the VGA
BIOS from when the board is running Linux under the factor BIOS

dd if=/dev/mem of=/tmp/vgabios.bin bs=1k count=64 skip=768

See also http://linuxbios.org/VGA_support

> The issue is the linuxbios.rom file is allready 256kb, Where would i
> change the size of this built "rom file" and what should i set it to:
> I tried setting this:
> option ROM_SIZE=256*1024
> to:
> option ROM_SIZE=200*1024
> Then doing:
> buildtarget via/epia-m
> cd via/epia-m/via_epia-m
> make
> This gives me this:
> ...
> ./buildrom linuxbios.strip linuxbios.rom payload 0x10000 0x12000
> payload (41187) + linuxbios (65536) size larger than ROM (73728) size!
> make[1]: *** [linuxbios.rom] Error 1
> ...
> Any suggestions would be welcome.

After the above dd command try these settings in your config:

option ROM_SIZE=192*1024
option ROM_SECTION_OFFSET=0x10000

It looks like the latter is 0 now.

This is all horribly unintuitive but should improve in v3.

If it still doesn't work you could try just inserting your image
right at the start of your 256kb linuxbios.rom like this:

dd if=vga56k.bin of=linuxbios.rom bs=56k count=1 conv=notrunc

But please try the other way first, I think it should work better.


More information about the coreboot mailing list