[SeaBIOS] Librem 15v3 hangs at Booting from Hard Disk...

Youness Alaoui kakaroto at kakaroto.homelinux.net
Tue May 15 19:49:11 CEST 2018

On Wed, May 9, 2018 at 9:14 PM, Philip C. <pchampon at gmail.com> wrote:
> Hello everyone!
> I've been having some issues with a laptop recently. My Librem 15v3 was
> bouncing along, until one day I ran into an apt-get upgrade issue. I
> attempted to fix the affected script by pointing it to the base directory
> busybox lived. The upgrade completed without any apparent issue.

This is clearly totally unrelated to SeaBIOS, and it looks like an
linux/grub installation problem.

> But, now no matter what I do, unattended boots hang on
> SeaBIOS (version rel-1.11.0-0-g63451fc)
> Booting from Hard Disk...
> _

If you see nothing after that, then that probably means that SeaBIOS
executed whatever was on the drive's boot sector and that failed to do
anything, so grub crashed or there was no grub in the first place, or
it was misconfigured and it stopped instead of showing some error
message, etc.. whatever the issue is, it looks like it's not related
to SeaBIOS.

> I have tried reinstalling the OS, using their live boot ISO. Each time, no
> matter which disk I configure (/dev/sda or /dev/nvme0n1), the install fails
> with the message
> Installation failed Failed to run update-initramfs on the target The exit
> code was 2
What OS is that ? What's the error of update-initramfs ? Did you try
to run update-initramfs manually to see what error it gives you ? I
remember seeing a similar error related to a busybox depedency (this
error https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=864143) and I
can't remember the exact fix, but it was something like : edit
/etc/initramfs-tools/initramfs.conf and change the "BUSYBOX=auto" to
either "y" or "n", one of them fixes it. Or maybe it was the file
/usr/share/initramfs-tools/conf-hooks.d/cryptsetup, or maybe you have
to add a line "BUSYBOXDIR=/bin" to the config..
Either way, you should fix whatever is causing that first.

> I have upgraded coreboot, no joy. I have also tried manually running grub,
> from the installer, ie
> mkdir /mnt/root
> cryptsetup luksOpen /dev/sda3 root
> mount /dev/mapper/root /mnt/root
> mount /dev/sda1 /mnt/root/boot
> grub-install --boot-directory=/mnt/root/boot /dev/sda
> update-grub2
Yeah, upgrading coreboot won't change anything if your hard drive
doesn't have a working grub installed on it.
I think your issue here might be that "update-grub2" will update the
grub files in /boot (from the live USB), not in /mnt/root/boot. I
would suggest to simplify your life and just "mount /dev/sda1 /boot"
so the update would work (even if you manually use grub-mkconfig -o
/mnt/root/boot, it will still scan some things in /boot, and it might
mess things up, so just mount it on top of the existing /boot and call

> The folks at purism/librem seem to be as confused as I am. Does anyone here
> have any insight into how I can fix this problem?
I haven't heard of this issue, usually, if it's related to coreboot, I
get asked for my opinion, but I suppose I wasn't poked about it by
tech support because it's a linux/install problem, and indeed, it's
not related to coreboot.

As for all that stuff about getting seabios debug, I don't know how
much that will help you. I'm sure all you'll see is something like
"jumping into boot sector" then nothing, it's not like the cbmem
console log will have the grub debug output in it saying "I'm about to
crash because I can't find my config" for example. Unless SeaBIOS sets
up a segfault handler or something prior to jumping into boot drive
and writes to the log a crash report, I have no idea if it does that.

> Thanks!
I hope that helps, good luck. And if you need more help, I suggest not
to spam this mailing list with non-seabios-development related
questions, you can continue emailing me directly.

More information about the SeaBIOS mailing list