[SeaBIOS] Problems booting legacy OSes on Chromebook Pixel 2015

Charles Howell charles.howell.2048 at gmail.com
Wed Apr 22 02:26:27 CEST 2015

(Apologies if this is the wrong list, but I'm not sure where else to post.)

I'm attempting to boot FreeBSD 10.1 (amd64) on a new Chromebook Pixel (via
a USB CD) and it hangs as soon as the kernel is loaded into memory.

I'd just assume it's a FreeBSD problem but I've also tried the latest
versions of OpenBSD and NetBSD with the same results.  In all three cases,
the bootloader loads and I can interact with it, toggle options, read
machine memory layout, enable safe mode, etc. but as soon as the kernel is
loaded into memory and it tries to execute, the machine hangs hard and I
have to hold down power for a few seconds to shut it off.

This leads me to believe it's a problem with SeaBIOS and/or its support for
this machine since I've booted BSDs on the Acer C720 with SeaBIOS just fine.

I've also tried with a USB key with an installed OS already in case it was
related to reading the CD, but with the same results.  The bootloader comes
up but no kernels will boot.

These were all tested with SeaBIOS version -20150225_120401-build122-m2 as
shipped with the device.

Can anyone offer any help?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.seabios.org/pipermail/seabios/attachments/20150421/3049d975/attachment.html>

More information about the SeaBIOS mailing list