[OpenBIOS] Request to help for Sparc arch - Solaris vm creation.

Mark Cave-Ayland mark.cave-ayland at ilande.co.uk
Tue Mar 15 22:51:30 CET 2016

On 15/03/16 12:22, Lsrtej P wrote:

> Hi  Openbios team,
> First of all I would like to thank you for the contribution to
> opensource community which is helping lot of developers like me to
> progress professionally.
> It would be great if you can help me with the problem I am facing with
> using qemu with openbios .
> I am trying to create a solaris  environment with sparc architecture  on
> an ubuntu 14.04  linux OS with help of qemu-system-sparc .
> When I am trying to load a solaris image using this qemu-system-sparc64
> i am getting the following  error message .
> When I tried debugging it I found that the openbios-sparc is not
> installed in ubuntu machine I am working with .
> This qemu-system-sparc64 uses a softlink which points to the directory
> /usr/share/qemu/openbios-sparc64 which is not found in the machine .
> I am stuck here , I am not sure what should be the contents of the above
> directory so that this sparc emulation works good .
> I tried to install the openbios from your official  website but failed
> in using it along with qemu .
> Can you please help me to get out of this situation or suggest me some
> way to create a 64 bit sparc solaris environment on linux os .
> Thanks in advance :)
> Warm Regards,
> Tej

Hi Tej,

Seems like you didn't get my reply for some reason? Fortunately it's
still listed in the archives at

Please let us know if you have any further questions :)



More information about the OpenBIOS mailing list