[OpenBIOS] Request to help for Sparc arch - Solaris vm creation.

Lsrtej P lsrtej.p at tcs.com
Tue Mar 15 13:22:49 CET 2016

Hi  Openbios team,

First of all I would like to thank you for the contribution to opensource 
community which is helping lot of developers like me to progress 

It would be great if you can help me with the problem I am facing with 
using qemu with openbios .

I am trying to create a solaris  environment with sparc architecture  on 
an ubuntu 14.04  linux OS with help of qemu-system-sparc .

When I am trying to load a solaris image using this qemu-system-sparc64 i 
am getting the following  error message .


When I tried debugging it I found that the openbios-sparc is not installed 
in ubuntu machine I am working with .

This qemu-system-sparc64 uses a softlink which points to the directory 
/usr/share/qemu/openbios-sparc64 which is not found in the machine .

I am stuck here , I am not sure what should be the contents of the above 
directory so that this sparc emulation works good .

I tried to install the openbios from your official  website but failed in 
using it along with qemu .

Can you please help me to get out of this situation or suggest me some way 
to create a 64 bit sparc solaris environment on linux os .

Thanks in advance :)

Warm Regards,
Notice: The information contained in this e-mail
message and/or attachments to it may contain 
confidential or privileged information. If you are 
not the intended recipient, any dissemination, use, 
review, distribution, printing or copying of the 
information contained in this e-mail message 
and/or attachments to it are strictly prohibited. If 
you have received this communication in error, 
please notify us by reply e-mail or telephone and 
immediately and permanently delete the message 
and any attachments. Thank you

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.coreboot.org/pipermail/openbios/attachments/20160315/84c9b3c0/attachment-0001.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: image/gif
Size: 17252 bytes
Desc: not available
URL: <http://www.coreboot.org/pipermail/openbios/attachments/20160315/84c9b3c0/attachment-0001.gif>

More information about the OpenBIOS mailing list