[OpenBIOS] Request to help for Sparc arch - Solaris vm creation.

Mark Cave-Ayland mark.cave-ayland at ilande.co.uk
Mon Mar 14 22:40:06 CET 2016

On 12/03/16 10:09, Lsrtej P wrote:

> Hi  Openbios team,
> First of all I would like to thank you for the contribution to
> opensource community which is helping lot of developers like me to
> progress professionally.
> It would be great if you can help me with the problem I am facing with
> using qemu with openbios .
> I am trying to create a solaris  environment with sparc architecture  on
> an ubuntu 14.04  linux OS with help of qemu-system-sparc .
> When I am trying to load a solaris image using this qemu-system-sparc64
> i am getting the following  error message .
> When I tried debugging it I found that the openbios-sparc is not
> installed in ubuntu machine I am working with .
> This qemu-system-sparc64 uses a softlink which points to the directory
> /usr/share/qemu/openbios-sparc64 which is not found in the machine .
> I am stuck here , I am not sure what should be the contents of the above
> directory so that this sparc emulation works good .
> I tried to install the openbios from your official  website but failed
> in using it along with qemu .
> Can you please help me to get out of this situation or suggest me some
> way to create a 64 bit sparc solaris environment on linux os .
> Thanks in advance :)
> Warm Regards,
> Tej

Hi Tej,

It sounds like there is a dependency missing somewhere between your QEMU
and OpenBIOS packages - as you can see at
https://launchpad.net/ubuntu/+source/openbios, OpenBIOS is packaged
separately under Ubuntu so I'm not sure why this hasn't been brought in?
Once the package is installed you should find that QEMU can locate the
binary automatically.

As regards running Solaris under Linux using qemu-system-sparc64 sadly
this is still a work in progress. Since the work is currently
unsponsored then myself and a few others are quite restricted in the
time we can spend on this so progress isn't as fast as we would like.

On the plus side, qemu-system-sparc64 is getting much more reliable with
newer QEMU/OpenBIOS releases and is now capable of booting
NetBSD/OpenBSD and (nearly) FreeBSD. So all I can say about Solaris for
the moment is watch this space :)



More information about the OpenBIOS mailing list