[flashrom] Problem while erasing chip prior write bin file.

Nico Huber nico.h at gmx.de
Tue Mar 6 21:55:40 CET 2018

Hello Luca,

On 06.03.2018 07:25, Luca Bacci Bonotti wrote:
> I tried with chip soldered and unsoldered. Same results.

same results? probably due to very different problems. Especially when
the chip is not part of a circuitry (that might already take care), you
have to connect all input pins of the chip. Also, very often, a series
resistor at least on the MISO output is required.

> I previously tried programming with raspberry PI but it was unable to see
> my chip.
> I have both CH341A and Raspberry Pi.

When you use the Raspberry Pi, make sure you set the `spispeed` parame-
ter of linux_spi to something reasonable (I'd start trying around 1000,
i.e. 1MHz), the default is OS dependent and often not reliable.

> Where should i connect /HOLD /WP on the CH341A ?

/HOLD should be pulled up towards VCC (i.e. using a series resistor,
10kOhm maybe), state of /WP usually only matters when the chip has some
write-protection set up, so either pull up towards VCC or down towards
GND (if in doubt, up).


More information about the flashrom mailing list