[flashrom] Problem while erasing chip prior write bin file.

Luca Bacci Bonotti luca.baccibonotti at gmail.com
Tue Mar 6 07:25:04 CET 2018

I tried with chip soldered and unsoldered. Same results.

The board is a router samknows SK-WB8
I erased uboot. Now samknows support sent me a bin file and I'm trying to
write this I attach some images.

I have a bunch of spare chips to try.

The connections to the chip are made following this

I previously tried programming with raspberry PI but it was unable to see
my chip.
I have both CH341A and Raspberry Pi.

When I tried with PI i followed this


Where should i connect /HOLD /WP on the CH341A ?

Do you have a schematics I can follow ?

Thanks a lot


Il 5 mar 2018 21:56, "Nico Huber" <nico.h at gmx.de> ha scritto:

Hello Luca,

On 05.03.2018 19:33, Luca Bacci Bonotti wrote:
> Hi I need help with flashrom . I'm unable to write a firmware using CH341A
> programmer, test clip pomona 5252 .

flashing in-system (ISP) is sometimes a very delicate procedure. How
and if it will work, depends on many things: 1. is the board designed
for ISP; if, follow the manual; if not 2. how do you power the flash
chip? through the board's regular power supply (strongly advised)? or
through the ch341a (discouraged unless you know exactly what you are
doing)? 3. are all input pins of the flash chip in a defined state?
(e.g. don't forget /HOLD and /WP). See also [1] and [2].

> The EEPRom I'm trying to write is
> S25FL128SAGMFI000.

Regarding ISP, the board the chip is soldered to matters more than the
chip. What board is it?

Hope that helps,

[1] https://flashrom.org/ISP
[2] https://flashrom.org/Common_problems
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.coreboot.org/pipermail/flashrom/attachments/20180306/2b2c7359/attachment-0001.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: IMG_20180306_002816.jpg
Type: image/jpeg
Size: 1947743 bytes
Desc: not available
URL: <http://mail.coreboot.org/pipermail/flashrom/attachments/20180306/2b2c7359/attachment-0002.jpg>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: IMG_20180306_002841.jpg
Type: image/jpeg
Size: 1896972 bytes
Desc: not available
URL: <http://mail.coreboot.org/pipermail/flashrom/attachments/20180306/2b2c7359/attachment-0003.jpg>

More information about the flashrom mailing list