[flashrom] Flashrom and Rampage IV Extreme issues.

wilson self wself00 at gmail.com
Fri May 17 14:24:52 CEST 2013

This may be a little much to follow but I'm going to try my best to
keep it on point.

I have about 12 ASUS Rampage IV Extreme motherboards.  One of the
first boards I worked on I was able to successfully read with flashrom
and then successfully write it to any other board I wanted too.  I
actually still use this ROM file to flash today.

The issue I have now is that I can not replicate this success.  The
process fails every single time, and when I say "process", essentially
it's reading the BIOS and writing it to a file for later use.  Before
attempting to write the ROM to another board using flashrom, I always
manually hexedit the file and change the MAC address.  This has worked
on a charm with the file that referenced earlier, the one that I use
every time with success.

The problem after flashing is this - the board doesn't boot up
immediately as it does with the "successful ROM", and it just hangs
with error code 00 on the LED.  Then I reboot it, and it has all of
the correct settings in the BIOS.  I go to boot the box in to the OS -
and the LAN controller is dead.  I see a message about

Now, for those unfamiliar with this board - it has 2 BIOS - you can
flip from one to the other and repair them as well by logging in to x
and cloning to y.  Vice versa.  Initially I thought maybe you could
only flash a BIOS you read with flashrom from BIOS y to BIOS y, or
BIOS x to BIOS x, or some other combination.  That has proven false.
The BIOS that works, to give as much detail as possible, was taken
from BIOS y and has been repeatedly flashed to BIOS x on over 9

flashrom version used in successful ROM:  r1564
flashrom version attempted to use with failure:  r1673
pastebin from ROM that doesn't work:  http://paste.flashrom.org/view.php?id=1640

I do not have a log from the success ROM - which stinks!  I didn't
realize this would never work again (or for the time being that I need
to figure it out).

TLDR:  flashrom read from ASUS RIVE has only worked once ever and can
load on to any other ASUS RIVE I've come across.  I can not replicate
this success anymore - by using another machine to read the BIOS and
then write it out to different motherboard.  This causes the onboard
NIC to die, and the post screen complains about not initializing the
NIC because it is corrupted.

More information about the flashrom mailing list