[flashrom] wiki patches 6.0?

Stefan Tauner stefan.tauner at student.tuwien.ac.at
Thu Mar 7 01:36:36 CET 2013

On Thu, 07 Mar 2013 01:07:28 +0100
Carl-Daniel Hailfinger <c-d.hailfinger.devel.2006 at gmx.net> wrote:

> Am 27.12.2012 20:16 schrieb Stefan Tauner:
> I think "note" is a misnomer and has the wrong type.
> A single string for an entire driver is not a good idea, as can be
> witnessed with the recent rayer_spi patches.

I don't see the problem or even the connection to those patches. They
all work on programmer devices, not on a programmer module. Those
devices should be listed similar to pci devices, no question, but that
is not the same problem. The note field is used to describe the property
of the whole module - sure it is currently a bit misued to list or
paraphrase the supported programmers, but those should just move to a
proper list for those kinds of programmers (as you outline below). the
note string might still be useful for other general information, that
can not be expressed by the other fields (there is not R/O status flag
for example) or such a device table. Admittedly the current type does
not fit its usage and vice versa.

> If you want to get rid of that union and have one combined dev_entry for
> USB/PCI and other programmers, why not? The "type" parameter of
> ft2232_spi could end up in there as well.
> Suggestions welcome.

The only problem I see with that is that the number of columns might
explode pretty quickly if we try to use one type for everything... and
that someone has to implement it :)

Kind regards/Mit freundlichen Grüßen, Stefan Tauner

More information about the flashrom mailing list