[flashrom] wiki patches 6.0?

Carl-Daniel Hailfinger c-d.hailfinger.devel.2006 at gmx.net
Thu Mar 7 01:07:28 CET 2013

Am 27.12.2012 20:16 schrieb Stefan Tauner:
> This is actually not about the wiki, but about the programmers.
> now that we have combined usb and pci device entries and put them
> together in a union with a char *note, i wonder why we have the union
> at all. the note might be very handy for normal programmers too (e.g.
> nvidia does not support writing, but this is not documented
> prominently...).
> It would also get rid of the annoying non-anonymous union... :)

I think "note" is a misnomer and has the wrong type.
A single string for an entire driver is not a good idea, as can be
witnessed with the recent rayer_spi patches.

If you want to get rid of that union and have one combined dev_entry for
USB/PCI and other programmers, why not? The "type" parameter of
ft2232_spi could end up in there as well.

Suggestions welcome.



More information about the flashrom mailing list