[flashrom] I lost my backup image and now my pc doesn't start...!

Marcos Felipe Rasia de Mello marcosfrm at gmail.com
Sun Jan 8 18:37:11 CET 2012

2012/1/8 İlhan Kahraman <ilhan805 at gmail.com>
> Hello there...,
>          My name is ilhan and I have just started to use a linux operating system, so I am new to all of these linux applications...
> While I am using this operating system, my self-confidence about diving into more tough stuff like flashtom-0.9.4. , has pushed
> me a downgrade flashing attempt on my motherboard, Asus M4A88TD-V EVO/USB3.
>           Actually, I have tried a downgrade flashing whit my mobo's official  applications, such as asus update and bupdater, in both FreeDos and
> Win7 environments but, this did not help me and kept saying that  " you are trying to load an old version of bios"...
>          So, I downloaded flashrom-0.9.4 source, installed it according to README file, read its manual
> (http://www.flashrom.org/trac/flashrom/browser/trunk/flashrom.8) and finally I made a backup file.
>          While playing around these linux applications and procrastinating my bios flashing, days gone by... Then one day :)... I just decided
> to flash my bios because of increased freezings and shutdowns in Win7, without being aware of that I have lost my usb stick in which I
> backup my mobos image whit using:
> sudo flashrom -r m4a88tdbackup
>        In other words; I, unconsciously, started the flashing whit out having a backup file...
> I simbly downloaded my old bios to my desktop (M4A88TD-V EVO/USB3 BIOS 1601) from:
> http://support.asus.com/download/download_item_mkt.aspx?slanguage=en-us&model=M4A88TD-V+EVO%2fUSB3
> I named this file as m4a88tdnew.ROM
> and continue with ...
> ilhan at ubuntu:~/Desktop$ >> sudo flashrom -E
> ilhan at ubuntu:~/Desktop$ >> sudo flashrom -w m4a88tdnew.ROM
>         After flashrom verified that the chip (winbond W25Q16) content and the file content was same, I hit the re-start button and this was the end of my computer :)
> It has not respond anything after that, not even any fan has cycled... I have already  tried the firmware CD and usb  which both contains the
> m4a88tu3.rom ( I think its  the equivalent of the amitool.rom in the asus due to user guide instructions), have clear the cmos without its battery and
> have un-plugged everything (expect cpu) in various combinations... All I have now, at start, CD-rom trying to read the CDs but it gives up quickly and
> the most important the cpu fan and the cpu ( I guess) does not work...
>        Trying all of this with out any luck, I decided to buy a new but cheaper mobo. I bought a Asus M4N68T-M ( with Nvidia MCP61 chipset (un-tested) and Eon EN25F80
> flash chip). I plugged everything on this mobo and it just working like a charm.
> With this new card I continued my attempts to flash my old cards chip but, I realized that I have no enough skills even making a simple confirmation of that: did I succeed it,
> in a right way. I decided to go in short way, made a simple search on the issue and found the yann's report (http://paste.flashrom.org/view.php?id=687)  about my old card.
> I requested from him to send me his back up image file via e-mail and he, kindly, said that he hadn't got any backup and directed me to the Asus support site which I already tried.
> After all of this, as a last resort, I  decided to stole your precious time for my unimportant problem... Can you help me about it. Can I resque my old card and how?
> I thought, if you can help me, in return of this help; I could contribute by sending you a report about both my new and old mobos :) I thing it is a good deal...:))
> So How can I flash my old card's chip in my new card and verify its flashed in a right way?
> I thank you very much by now for just reading this long.
> Have a good day....
> --
> Undergraduate  Student at
> Materials Science & Engineering Department
> and
> Department of Industrial Design,
> Anadolu University, Eskisehir,
> Turkey
> e-mail: ilhan805 at gmail.com


Did "sudo flashrom -w m4a88tdnew.ROM" show any errors? If no, I can
only think this board requires some magic from the official update
tool to work...

To restore your old chip contents using the new board you will need
hot swap. Before continuing see if both chips have the same protocol
and voltage. Power on your new board and load Linux. With the system
powered on, remove with care the flash chip and put the "dead" one in
place. Run flashrom -E and -w as usual. Power off and put each chip in
its original place. However I don't think it will help if your first
update attempt apparently was completed without errors.

You can also use the DOS tool. Maybe it's the solution:

bupdater /iBIOS.ROM /pc /g

bupdater /oBKP.ROM

The bios filename has *no* space after the "/i" and "/o" switches.

Good luck.


More information about the flashrom mailing list