[flashrom] [PATCH] Rename identifiers called 'byte'

Carl-Daniel Hailfinger c-d.hailfinger.devel.2006 at gmx.net
Thu Feb 25 12:31:24 CET 2010

On 25.02.2010 12:29, Michael Karcher wrote:
> Am Donnerstag, den 25.02.2010, 12:03 +0100 schrieb Carl-Daniel
> Hailfinger:
> [renaming "byte" to "lpc_8a" in MCP chipset init]
>> No objection from a technical POV, but I really dislike the name lpc_8a.
>> I don't have a good suggestion for a better variable name, though. Maybe
>> mcp_bustype?
> I really dislike mcp_bustype, because the register 0x8a contains more
> info than just the bus type, but we don't know what the other bits mean.
> As we seem to have completely different preferences on identifier naming
> (which is OK), I suggest to replace the generic name "byte" by the
> generic name "val". Would that be OK with you?

Sure, good idea.


"I do consider assignment statements and pointer variables to be among
computer science's most valuable treasures."
-- Donald E. Knuth

More information about the flashrom mailing list