[coreboot] [skylake] Can not turn monitor on

Nico Huber nico.h at gmx.de
Wed Oct 3 16:48:55 CEST 2018

Hi Zheng,

On 10/3/18 4:06 PM, Zheng Bao wrote:
> I tried both the vgabios extracted in linux /sys/ and seavgabios.

don't know why GOP+SeaVGABIOS fails but an Intel VBIOS extracted from
memory never worked for me. You might have more luck by extracting it
from a firmware image with uefitool.

> The debug message seems to be good, which is attached.

Looks rather good:

  Found FB @ c0000000 1440x900 with 32 bpp (5760 stride)

This means most already succeeded. The FSP/GOP driver run and set a
framebuffer up. Maybe the problem is that the backlight stays dark?
Since Skylake, coreboot lacks all backlight initialization. Only the
GOP driver can set it up and whether that works depends on your VBT.

I would try with a bright light to spot something on the screen to
confirm if it's a backlight issue.

Where did you get the VBT from?


PS. Btw. the lack of backlight initialization is all that keeps you
    from using a reliable, pure open-source solution. libgfxinit
    already works well for Skylake. Just coreboot doesn't do it's
    job for the backlight.

More information about the coreboot mailing list