[coreboot] Lenovo Thinkpad X201: recipe for target 'add_intel_firmware' failed

Sam Kuper sam.kuper at uclmail.net
Sun Mar 19 19:06:14 CET 2017

I am trying to build Coreboot for the X201, and to improve the
Coreboot wiki's X201 page as I go along.

I am presently following the instructions at this permalink:

(I decided to skip the step to neuter the ME:
. Maybe I will try neutering the X201's ME another day, but first of
all I would like to at least achieve Coreboot running on the X201.)

Everything went fine, so far, until this step:

Let me describe how I attempted to implement that step.

I ran `make distclean`.

I ran `make nconfig`, and selected:

- "Lenovo" under Mainboard > Mainboard vendor

- "ThinkPad X201 / X201s / X201t" under Mainboard > Mainboard model

- "Add Intel descriptor.bin file" under Chipset

- "Add Intel ME/TXE firmware" under Chipset

Then I pressed F9 ("Exit") and saved the config to the default
location ( coreboot/.config ).

Then I ran `make`, which seemed to be going fine until the following output:

    Compile IFDTOOL
    HOSTCC     util/ifdfake/ifdfake
    DD         Adding Intel Firmware Descriptor
src/southbridge/intel/common/firmware/Makefile.inc:50: recipe for
target 'add_intel_firmware' failed
make: *** [add_intel_firmware] Error 1

Can anyone suggest how to overcome this error?

I have attached the .config generated by `make nconfig`, and the full
output of `make`, in case that is useful.

Many thanks!
-------------- next part --------------
A non-text attachment was scrubbed...
Name: .config
Type: application/octet-stream
Size: 20596 bytes
Desc: not available
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20170319/2c48639c/attachment.obj>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: x201.log
Type: text/x-log
Size: 26049 bytes
Desc: not available
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20170319/2c48639c/attachment.log>

More information about the coreboot mailing list