[coreboot] Black screen during SeaBIOS boot

Youness Alaoui kakaroto at kakaroto.homelinux.net
Fri Dec 15 23:57:53 CET 2017

Try a 'cbmem -t' to see how long coreboot itself took to boot. There
might be some delay somewhere causing it to take longer to boot
(current system I'm on, it takes 8 seconds, and on other systems I saw
it take 15 seconds, because it waits for the ME to respond until it
times out) so it might not all be seabios' fault.
Also I just tried removing the VGABIOS and setting Coreboot to run the
GOP driver, and I got a black screen in seabios (even in grub, screen
shows text only after linux boots and inits the driver I think). I'd
suggest you try the proper vgabios and no GOP driver, just to see if
it helps, then see what happens without the vgabios.
Note: i only have one VGA device here.

On Fri, Dec 15, 2017 at 12:59 PM, awokd via coreboot
<coreboot at coreboot.org> wrote:
> On Fri, December 15, 2017 11:10 am, Daniel K wrote:
>> Starting up with coreboot and SeaBIOS, the screen is completely black for
>> around 30 seconds before my on-disc bootloader (grub2) is loaded and
>> displayed.
>> I'm assuming SeaBIOS counts down with some timer before launching the
>> on-disc bootloader but I don't see anything.
>> I want to use coreboot in text-mode so I'm not including a VGA rom.
> That might be why you are getting the delay. Try adding it and see. I ran
> into the delay too and think that's what fixed it.
>> According to lspci (attached), I have two VGA devices:
> You might need to edit src/device/Kconfig with:
>         bool
>         default y
> --
> coreboot mailing list: coreboot at coreboot.org
> https://mail.coreboot.org/mailman/listinfo/coreboot

More information about the coreboot mailing list