[coreboot] Nehalem not booting with two ram sticks

Kyösti Mälkki kyosti.malkki at gmail.com
Tue Nov 22 20:50:16 CET 2016


On Tue, Nov 22, 2016 at 9:30 PM, Charlotte Plusplus <
pluspluscharlotte at gmail.com> wrote:

> I have had similar issues with Corsair ram on the W520 recently: sometimes
> not booting at all, sometimes being unstable (in memest) after a succesfull
> raminit.
> The only way I could get the 4 dimms to work was to hardcode some SPDs, or
> set the MCU to a much slower speed.
> Like you, I found removing even 1 stick did help a lot: the raminit
> succeeded much more frequently as a higher MCU, even if this MCU still
> lower than the one the RAM is rated for, or that worked in the factory bios.
> I tried using the MRC blob to compare the timings, but I must have done
> something wrong in my code as it didn't work at all

See following commits:
 5c10abe nb/intel/sandybridge: increase MMCONF_BASE_ADDRESS
 0306e6a intel/sandybridge: Fix builds with System Agent blob
 f9c4197 northbridge/sandybridge/raminit_mrc.c: fix missing include

My guess is something is really wrong in the raminit code. I read up too
> much specs and code for no result, so I just gave up on this.
> Hopefully more people getting similar problems will mean the MRC will be
> added back as an option next to the native raminit. This would facilite
> comparison on all boards, and identification of whatever bug there may be.
> (imagine figuring out native video init issues if there was no way to use a
> VGA option rom)
Was MRC blob ever really an option for lenovo/xxx boards? I did not check

Anyways, currently I have no trouble on samsung/lumpy changing between MRC
and native raminits. And with native raminit it should now boot much faster
than two weeks ago.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20161122/54a0fbc3/attachment.html>

More information about the coreboot mailing list