[coreboot] X220 Wifi Suspend

Nico Huber nico.h at gmx.de
Fri Nov 18 20:52:41 CET 2016


On 18.11.2016 18:08, Tyler Cipriani wrote:
> I recently flashed my Lenovo ThinkPad X220 with Coreboot and a SeaBIOS
> payload. I made an attempt to document the whole process[0].
> Initially, everything seemed to work fine. I was able to boot to SeaBIOS
> which handed off to a Debian testing install (Stretch).
> Now that I've used this laptop a bit, I realized that wifi appears
> hardware-blocked after returning from suspend. I've found lots of pages
> online with "one weird trick" to fix this, and have tried many of those
> tricks to no avail :(
> I've tried a couple of different Coreboot configs[1][2] neither of which
> made any difference. After re-flashing the old proprietary ThinkPad BIOS
> wifi comes back from suspend just fine.
> I've tried both the standard intel wifi card and a card from
> ThinkPenguin that uses the ath9k driver[3] using the coreboot config.
> Any help or pointers anyone could give me would be much appreciated!

it's likely caused by a regression we had lately, caused by [4] and now
fixed by reverting it [5]. Feel free to try again with latest coreboot.

Hope that helps,

[4] commit 83df672d2ce481686c5c4e04625bc1b97d7a4a8b
    ec/lenovo/h8: don't load configuration when booting from s3

[5] commit 6444b52ce06236c621a88003b2fca107feaf9bff
    Revert "ec/lenovo/h8: don't load configuration when booting from s3"

> -- Tyler
> [0].
> <https://tylercipriani.com/blog/2016/11/13/coreboot-on-the-thinkpad-x220-with-a-raspberry-pi/>
> [1]. <http://pastebin.com/Ah0fxBp5>
> [2]. <http://pastebin.com/1yNSTfyj>
> [3].
> <https://www.thinkpenguin.com/gnu-linux/penguin-wireless-n-half-height-mini-pcie-card>

More information about the coreboot mailing list