[coreboot] Intel: After suspend/resume `cbmem -l` fails with `Program cbmem tried to access /dev/mem between f0000->1f0000.`

Paul Menzel paulepanter at users.sourceforge.net
Tue Jan 6 09:01:51 CET 2015

Am Sonntag, den 04.01.2015, 12:44 +0100 schrieb Michał Masłowski:
> > On the i945 based Lenovo X60, running `cbmem -l` (or any other option)
> > works fine. Suspending and resuming the system, running any `cbmem`
> > commands does *not* work anymore.
> Running cbmem -Vl on my X60t shows that the first run finds the table in
> the first 1 MiB of memory, after suspend it doesn't and fails to mmap
> memory containing RAM after the first 1 MiB.

Does somebody have a coreboot log from serial or USB for cold boot and
resume, please? I am unable to get one right now, because the docking
station is not here.

> >         [ 2834.560179] Program cbmem tried to access /dev/mem between f0000->1f0000.
> Kernel code prevents accesses to RAM, allowing only access to the first
> 1 MiB and MMIO.
> > Do you have any idea, why this happens? Is that a Linux error?
> Using dd, grep and hexdump shows that the coreboot table entry at memory
> address 0x500 gets zeroed.  /proc/iomem considers that address
> "reserved".

Thank you for the analysis.


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 181 bytes
Desc: This is a digitally signed message part
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20150106/ef683065/attachment.asc>

More information about the coreboot mailing list