[coreboot] Intel: After suspend/resume `cbmem -l` fails with `Program cbmem tried to access /dev/mem between f0000->1f0000.`

Michał Masłowski mtjm at mtjm.eu
Sun Jan 4 12:44:25 CET 2015

> On the i945 based Lenovo X60, running `cbmem -l` (or any other option)
> works fine. Suspending and resuming the system, running any `cbmem`
> commands does *not* work anymore.

Running cbmem -Vl on my X60t shows that the first run finds the table in
the first 1 MiB of memory, after suspend it doesn't and fails to mmap
memory containing RAM after the first 1 MiB.

>         [ 2834.560179] Program cbmem tried to access /dev/mem between f0000->1f0000.

Kernel code prevents accesses to RAM, allowing only access to the first
1 MiB and MMIO.

> Do you have any idea, why this happens? Is that a Linux error?

Using dd, grep and hexdump shows that the coreboot table entry at memory
address 0x500 gets zeroed.  /proc/iomem considers that address
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 818 bytes
Desc: not available
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20150104/2fe827a1/attachment.asc>

More information about the coreboot mailing list