[coreboot] i945: AHCI timeout with Crucial m4 SSD 2.5 in SeaBIOS on cold boot

Paul Menzel paulepanter at users.sourceforge.net
Fri Sep 19 22:32:40 CEST 2014

Dear Sven,

thank you for your reply. I moved the discussion to the SeaBIOS mailing
per Kevin’s request [1].

Am Sonntag, den 14.09.2014, 22:05 +0200 schrieb Sven Schnelle:
> Am 14.09.2014 10:10, schrieb Paul Menzel:

> > testing the SSD Crucial m4 SSD 2.5 256 GB SATA 6 Gb/s on the Lenovo
> > X60t, the payload SeaBIOS 1.7.5-40-g5109366 does not detect the drive.
> >
> >          […]
> >          32.705: |7f673000| WARNING - Timeout at ahci_port_setup:466!
> >          32.705: |7f673000| AHCI/0: device not ready (tf 0x80)
> >          33.205: |7f673000| WARNING - Timeout at ahci_port_reset:336!
> >          […]
> >
> > Hitting Ctrl + Alt + Delete, the drive is detected.
> >
> > It is also reproducible on the Lenovo T60 with coreboot from four years
> > ago and SeaBIOS 1.7.0-91-g7a39e72.
> >
> > The drive is detected correctly on the ASRock E350M1 with coreboot and
> > SeaBIOS 1.7.5.
> >
> > Please find the whole serial log from SeaBIOS below.
> >
> > Does that look like a coreboot or SeaBIOS problem?
> It's a SSD problem. I have the exact same SSD in my chromebook, and the 
> SSD needs at least 500ms after power up to do it's initialization. If
> i use a unpatched coreboot, i get the same errors (and a 5s stall
> after resume from S3)

By the way, could you please attach the patch you use?

Which firmware does your drive have?

According to the label on the SSD I have, firmware revision 0309. Hdparm
should also list the firmware revision with `hdparm -i /dev/sda`, I

Kevin suggests an upgrade of the firmware? Depending on whether you
already tried the latest firmware revision 070H from April 2nd, 2013
[2], I would put that off, as there are reports later revisions do not
run as stable as 0309 [3] (at least 000F).

        The other improvements on 000F are probably not needed and some
        people (e.g. mac users) seem to find 0309 more stable than 000F.
        But if you have earlier than 0309 you should upgrade.

Changelog for 070H:

      * Like recent firmware versions, version 070H has improvements
        over versions 000F which are specific for Windows 8 and new
        UltraBook systems, although systems running Windows 7 and other
        operating systems may also see improvements. Any m4 firmware
        version will function normally in Windows 8, even without these
        performance improvements.
      * The following is a summary of changes between 040H and 070H,
        which are independent of operating system:
      * Resolved a power-up timing issue that could result in a drive
        hang, resulting in an inability to communicate with the host
        computer. The hang condition would typically occur during
        power-up or resume from Sleep or Hibernate. Most often, a new
        power cycle will clear the condition and allow normal operations
        to continue. The failure mode has only been observed in factory
        test. The failure mode is believed to have been contained to the
        factory. This fix is being implemented for all new builds, for
        all form factors, as a precautionary measure. The fix may be
        implemented in the field, as desired, to prevent occurrence of
        this boot-time failure. To date, no known field returns have
        been shown to be related to this issue. A failure of this type
        would typically be recoverable by a system reset.

That last item might even be a fix for the issue we experience, so I am
curious if you have tried it.



[1] http://www.seabios.org/pipermail/seabios/2014-September/thread.html#8302
[2] http://www.crucial.com/usa/en/support-ssd-firmware
[3] http://forums.crucial.com/t5/Solid-State-Drives-SSD/How-do-I-upgrade-Firmware-in-Linux-ATA-M4-CT064M4SSD2-locking-up/td-p/96239
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 181 bytes
Desc: This is a digitally signed message part
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20140919/69ccbf99/attachment.asc>

More information about the coreboot mailing list