[coreboot] Trouble with coreboot for Roda RK9

Nico Huber nico.huber at secunet.com
Thu Feb 13 10:56:01 CET 2014

Hello Dmitry,
> Why can't I read the condition GP1 - GP4?
> When I start the program superiotool with original bios, it shows regular
> results, when I start the program superiotool with coreboot the program
> shows 0 at GP1-GP4. It is in GP4 the DIP switcher locates  to chose the
> type of  LCD.
I'm sorry, but I can only confirm your problem. I tried reading those
GPIOs with the coreboot version we had on our RK9 and everything worked
out. After flashing the current upstream version, the VGA output was
garbled. So this is a regression which needs further investigation. I
can't currently work on this, but if you like to bisect the problem:
I guess, commit 11a7db3 should be a working starting point.

Kind regards,

M. Sc. Nico Huber
Berater, SINA-Softwareentwicklung
Public Sector
secunet Security Networks AG

Tel.: +49-201-5454-3635, Fax: +49-201-5454-1325
E-Mail: nico.huber at secunet.com
Mergenthalerallee 77, 65760 Eschborn, Deutschland

Sitz: Kronprinzenstraße 30, 45128 Essen, Deutschland
Amtsgericht Essen HRB 13615
Vorstand: Dr. Rainer Baumgart (Vors.), Willem Bulthuis, Thomas Pleines 
Aufsichtsratsvorsitzender: Dr. Peter Zattler

More information about the coreboot mailing list