[coreboot] f2a85-m related topics

Martin Roth martin.roth at se-eng.com
Wed Mar 27 16:32:32 CET 2013

On 03/26/2013 01:11 PM, Rudolf Marek wrote:
> Hi all
> The board is finally in. I'm aware that David bought it (i think he 
> has f2a85-m CSM version which is USA specific), is there anyone else? 
> PaulePanter maybe?
> Has anyone tried "hot flashing" ? It seems linux crashes if I simply 
> unplug the flash. I tried to work around and disabled SMI by software. 
> But I want to be sure it happens also to other people.
> The issue with SeaBIOS is gone. I will post some coded verb fix. Is 
> there a way how to extract verbs for codec from original system? I did 
> simple: cat /sys/class/sound/hwC1D0/init_pin_configs
> Is it all?
> The last, so far known issue is that SeaBIOS likes to boot only from 
> first AHCI port. I need to check this.
> Thanks
> Rudolf
Hi Rudolf,
   I just got a f2a85-m CSM to test with here at Sage, but we're still 
waiting for a CPU to drop in before we can do anything.

I suspect that the crash might be caused by the USB3 controller.  It 
could also be the IMC, but I think this is less likely.  Both of these 
run code directly from the ROM chip.  If you unplug the chip while 
they're trying to fetch, it's not surprising that "Bad Things" happen.  
You could test for this by doing a build that removes these roms and 
after booting from that version, see if it still crashes when the chip 
is pulled.

The ahci issue with seabios sounds like an issue I fixed in AGESA a 
couple of months ago.


More information about the coreboot mailing list