[coreboot] AsRock E350M1 report: Ethernet adapter not initialized

Paul Menzel paulepanter at users.sourceforge.net
Tue Apr 16 17:04:22 CEST 2013

Dear openvoid,

welcome to coreboot and thank you for your report!

Am Sonntag, den 14.04.2013, 22:09 +0400 schrieb openvoid:

> I get E350M1 motherboard

In #coreboot on <irc.freenode.net> openvoid confirmed that this is the
ASRock E350M1 and not the ASRock E350M1/USB3.

> and want to report some things i tested.

Thanks. I assume you also opened the ticket 192 in coreboot’s Trac
instance [1]. Thanks for this, but we should try to keep discussing this
on this list (one thread for each problem) as the Trac tracker is not
used that much anymore.

What payload do you use?

> This can be especially interesting to Paul Menzel and some others, who
> i see adding patches related to this motherboard few last months.

Yes, thanks a lot!

> Most information is available on http://www.coreboot.org/ASRock_E350M1
> so i post only difference with my experience.


> I cannot surely say after which commit regressions occur. I was using
> gcb891de as latest 

The g at the very beginning stands for git, so here is the revision you

        $ git show cb891de
        commit cb891de07ffe605897010776fc1becc9589d3648
        Author: Paul Menzel <paulepanter at users.sourceforge.net>
        Date:   Sat Apr 13 18:35:32 2013 +0200

            cbmem: parse_cbtable: Use length modifier `ll` `u64`

            Reviewed-on: http://review.coreboot.org/3084

> and ec6f043 as old surely working (most close to latest progressive
> changes on wiki page).

        $ git show ec6f043
        commit ec6f043c253355483bd065c39adc91bad2647ee9
        Author: Denis 'GNUtoo' Carikli <GNUtoo at no-log.org>
        Date:   Thu Jun 14 14:19:09 2012 +0200

            llshell: fix build without romcc

            Reviewed-on: http://review.coreboot.org/1101

I have reordered your message, so I can comment on the problems now.
> Wiki update:
> PS/2 Keyboard - NOT working - with init_ps2_keyboard option it blinks
> during post but still not working in OS
> PS/2 Mouse - NOT working

I have different experience. Once it did not work at all. The other time
it worked somewhat but pressing one key it appeared several times on the
screen as reported to the list [2][3].

> Regressions:
> Ethernet - NOT working

Thanks for finding the responsible in [1] using bisection!

> POST time 5-10 seconds instead of 1-3

Same here. Please see my message to the mailing list [4]



[1] https://tracker.coreboot.org/trac/coreboot/ticket/192
[2] http://www.coreboot.org/pipermail/coreboot/2013-March/075584.html
[3] http://www.coreboot.org/pipermail/coreboot/2013-April/075586.html
[4] http://www.coreboot.org/pipermail/coreboot/2013-April/075602.html
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 198 bytes
Desc: This is a digitally signed message part
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20130416/1723ae97/attachment-0001.sig>

More information about the coreboot mailing list