[coreboot] tyan s2882-d not booting

Peter Stuge peter at stuge.se
Tue Dec 4 03:07:14 CET 2012

Kui Zhang wrote:
> I got some old boxes:  tyan s2882-d, dual opteron processors, 16G RAM.
> 512K bios flash.
> So far, I am not able to get it to boot. It appears to reboot during
> CPU init.
> If anyone got coreboot working on this board, which revision did it
> worked last ?

I don't have it working, but I would suggest to try either the last
commit which touches the mainboard files, or the last commit which
touches the platform component files (northbridge and southbridge).

git log with appropriate parameters makes it easy to find these
commits from the history.

> Ram4
> v_esp=000cff48
> testx = 5a5a5a5a
> Copying data from cache to RAM -- switching to use RAM as stack... Done
> testx = 5a5a5a5a
> Disabling cache as ram now
> Clearing initial memory region: Done
> Loading image.
> CBFS: Looking for 'fallback/coreboot_ram'
> CBFS: found.

It looks like raminit worked, but the fact that executing from RAM
does *not* work speaks against that.

> No error during make. I tried building on x86_64 and x86.

Which toolchain did you use when building? Please run

make crossgcc

in the top-level coreboot directory to build a known-good toolchain
if you haven't already. After running that command, you can verify
that the toolchain will be used the next time you compile coreboot:

cat .xcompile

should show various paths into a subdirectory with an xgcc/ path


More information about the coreboot mailing list