[coreboot] IDE and Compact Flash handling in AMD Geode LX800 and CS5536

Darmawan Salihun darmawan.salihun at gmail.com
Mon Dec 13 12:10:55 CET 2010


The CF is the primary master and the IDE interface is the primare slave.

I've tried to enable the PATA MSR but lspci -vvv displays the IDE controller
as [disabled] (base at 1f0h and 170h in memory space). Is there any register
in the pci-to-isa bridge that I should reprogram?



On 10 Dec 2010 16:17, "Darmawan Salihun" <darmawan.salihun at gmail.com> wrote:


Unfortunately, the board is a custom-build board.

I'm currently waiting for information from the board vendor.
Yes, I've tried using only the PATA interface (there's a PATA
connector on the board).
With the stock BIOS (AMI), devices on the PATA could be detected but
couldn't be written into,
MBR loading occasionally failed as well.

I'm still on the process of porting coreboot to this particular board.

As for the cs5536_pata.msr=1, haven't try that one. I'll test ASAP.

Thanks for the hints.


On 12/10/10, Peter Stuge <peter at stuge.se> wrote:
> Darmawan Salihun wrote:
>> There's a CF interf...

-= Human knowledge belongs ...
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20101213/715a3988/attachment.html>

More information about the coreboot mailing list