[coreboot] [v2] ACPI on m57sli

Harald Gutmann harald.gutmann at gmx.net
Wed May 27 20:54:22 CEST 2009

On Wednesday 27 May 2009 19:04:53 you wrote:
> Hi Harald,
> Thanks for the response.
No problem, it's also in my interest to get ACPI working on M57SLI.

> There were some prototype/pointer type issues I had to fix to get the
> patch compiled in the latest svn code, which was in some checksum
> calculation call. Maybe that's related?
The problem with the FACP checksum always occurred here. I don't know if this 
is related to your changes, but for me it has never worked.

> I'll find where the mac address is stored and replace it with the same
> one in the factory bios. I thought I did that already long ago, but
> maybe the location has been changed since?

> The PCI interrupts seems to be the thing that is fixed by your patch,
> because the nvidia display driver used to complain about interrupts not
> working without your patch, now it works fine.
This just seems to be, because IRQ routing is stored is some different tables.
Until my patch it used to be the MPTABLE which is filled through the mptable.c, 
which is not really fixed now, but Linux uses now the ACPI table for the IRQ 
routing descriptions, which is in fact the vendors dsdt.asl, and this one we 
are not allowed to use in coreboot.

So this problems are not fixed, but the ACPI layer just "hided" this problem.
Most for most of the mptable stuff I have some patches, which also allow to use 
the graphics device without ACPI enabled coreboot.
This should be no big thing to get fixed, because most of the work is already 
done, it would be good if someone could check this on his hardware, and the 
code too. (Fixing it in mptable.c is not really necessary when you put a 
correct ACPI table in the dstd.asl, but I'd prefer this solution to fix/test, 
because the changes are quite marginal.)

When we have a fine/correct mptable.c it should be not really much work to set 
up an own, short, free dsdt.asl and maybe then use the mptable just when ACPI 
is turned off in the config.

> Does it also contain fixed powernow speed/voltages for YOUR processor?
> Linux complains about a device not found, which is probably your
> processor, which is different from mine...
PowerNow has worked here, but it offered one more option on the processor for 
setting it's speed. I checked the values in cpuinfo or with x86info and 
calculated had a look at the bios ... manual from AMD for my processor and 
everything seemed to be correct.

Also on the IRC channel (or even on the ML?) some people thought that this is 
a "bug" in the vendors bios to not offer that mode.

> ACPI power off works fine, which is the most important for me (and
> probably most others...).
Yes, that works fine on v2 too, and i think it should be quite easy to add some 
more ACPI features based on the code from Rudolf Marek who implemented S3 
wakeup on his board.

> I only have a V2 board.
Me too, but i don't wan't to break something for v1 on committing some changes 
which are proved to work on v2 only.

> > Furthermore to get M57SLI ACPI support "complete" the acpi_fill_mcfg part
> > should be done, but right now it seems that there is no address available
> > in the cb code which represents the address needed.
> Is that essential?
Not really, and I think this could be ignored, but it would be fine to have it, 
so that booting is "error-free".

> Thanks, I'll keep you posted.
> Ronald.

Kind regards,

PS: I think it would be better to keep this discussion on the mailing list, so 
everyone can post his hints/opinions/suggestions to that topic.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 197 bytes
Desc: This is a digitally signed message part.
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20090527/13565673/attachment.sig>

More information about the coreboot mailing list