[coreboot] SVN Coreboot-v3 with SVN OpenBIOS payload panics on boot with qemu

Myles Watson mylesgw at gmail.com
Tue Jan 27 21:24:23 CET 2009

On Tue, Jan 27, 2009 at 12:33 PM, Mark Cave-Ayland
<mark.cave-ayland at siriusit.co.uk> wrote:
> Myles Watson wrote:
>> boot eax = 0x2badb002
>> boot ebx = 0xf0000
>> boot arg = 0x2
>> That doesn't look good. 0x2badb002 instead of 0x100060 in the working
>> log.  I don't know much about OpenBIOS, but I'm happy to help if it
>> looks like the resource allocation is breaking it.  Have you tried it
>> without the printk buffer enabled?
>> Thanks,
>> Myles
> Hi Myles,
> Possibly - I'm still quite new to both codebases at the moment. Based upon
> your advice I just tried undefining "CONSOLE_BUFFER" in "make menuconfig",
> and then did a complete "make clean; make" once again. Sadly after
> installing this coreboot/OpenBIOS, qemu SVN still fails to boot with exactly
> the same error.

Thanks for trying it.  It was the other big change besides the
resource allocator since the working log.

I used coreboot v2 and it doesn't fail.  Buildrom makes it easy to
switch between the two.  You just have to

svn up work/openbios/svn

to get the latest instead of Rev 186, after you've configured it to
use openbios.

I still get all the

Cannot manage 'PCI host bridge' PCI device type 'pci':
 8086 1237 (6 0 0)
Cannot manage 'ISA bridge' PCI device type 'pci':
 8086 7000 (6 1 0)
Cannot manage 'IDE controller' PCI device type 'ide':
 8086 7010 (1 1 80)
Cannot manage 'misc PCI bridge' PCI device type 'pci':
 8086 7113 (6 80 0)
Cannot manage 'VGA controller' PCI device type 'display':
 1013 b8 (3 0 0)

Messages, but then I get:

Welcome to OpenBIOS v1.0RC1 built on Jan 27 2009 19:55
  Type 'help' for detailed information

[x86] Booting default not supported.

0 >

Can you enable more debugging and/or figure out what is being accessed
at the failure?  I'll help from the coreboot side if I can.


More information about the coreboot mailing list