[coreboot] Coreboot fails to initialize on ASUS A8V-E SE

Knut Kujat knuku at gap.upv.es
Thu Dec 10 18:03:12 CET 2009

Knut Kujat escribió:
> ron minnich escribió:
>> On Thu, Dec 10, 2009 at 2:33 AM, Knut Kujat <knuku at gap.upv.es> wrote:
>>> Sorry for spamming the maillist!!!
>>> but it stops again at: PCI: 00:02.0 cmd <- 07 I haven't changed anything!
>>> whats wrong? :(
>> random halts and errors --> I think myles is right grow stack but
>> maybe it is memory.
>> ron
> no, I don't use crossgcc I tried to install it with ./buildgcc but it
> fails on downloading the second tar ball. The weird thing is that it
> exactly once passed this point and it got to build the apci table. But
> as I said that only occurred once and trust me I tried it a whole
> bunch of times. I switched my dimms several times in different slots I
> tried with only one to see if the other is broken or something but
> nothing. So I guess next thing will be stack size.
> Thanks,
> Knut Kujat

I tried pushing the stuck to 2000 4000 and even 20000 but nothing it
still stucks at the same place: setting up some printk I found out that
it hangs :

void pci_write_config16(device_t dev, unsigned where, uint16_t val)
    struct bus *pbus = get_pbus(dev);
    ops_pci_bus(pbus)->write16(pbus, dev->bus->secondary,
dev->path.pci.devfn, where, val);  <<<<<< HERE!!

btw, what do you mean by memory problem because as I said before I
already switched my dimms whithout any results.
I attached the whole boot sequence.

I really appreciate your help, thx!

Knut Kujat.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20091210/17fb3938/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: coreboot.log
Type: text/x-log
Size: 196653 bytes
Desc: not available
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20091210/17fb3938/attachment.log>

More information about the coreboot mailing list