[LinuxBIOS] EPIA M-II (CF Boot)

Jun OKAJIMA okajima at digitalinfra.co.jp
Fri Dec 2 02:33:45 CET 2005

Gooood! but you can run X? This is the key. And I can not yet.

                   --- Okajima, Jun. Tokyo, Japan.

>I would like to add my name to the list of people who have suceeded with the 
>The VGA BIOS offset given by Nick Barker was no good for my board (Model: 
>EPIA-Mii12000 LVDS), I had to use skip=786432 as suggested by Jun.
>I am having problems with the kernel recognising the CF device as hde1 
>though. I am able to manually mount hde1 from a diagnostics shell within the 
>initrd after running cardmgr, so it is available, but once I exit the shell 
>the kernel is saying it can't find hde1.
>I'm not sure if Nick used devfs with his setup, but that's not available for 
>my 2.6.14 kernel. I have used mknod to create the device, and also tried 
>using udevstart but still have the same problem. I wonder if it's something 
>to do with me having all the pcmcia stuff compiled directly into the kernel 
>instead of as loadable modules? Unfortunately I'm quite rusty with Linux!
>Anyway, I suppose this is a bit off topic. The LinuxBIOS seems to work 
>great, thank you, and big thanks to Nick for all your work on the EPIA M2.
>Oh, by the way, I used Award's AWDFLASH to flash linuxbios.bin. Using the 
>undocumented /F option. Nick's HOWTO talked about a flash_and_burn utility 
>which wasn't in the tree, and the flashrom tool just wouldn't compile for me 
>for some reason. AWDFLASH worked, except for some strange quirks. I can't be 
>certain if it was due to bad floppies on my part, but for some reason I felt 
>I was having better success overwriting a good bios, rather than re-trying 
>on a failed flash. The machine would go loopy sometimes. It all works now 
>LinuxBIOS mailing list
>LinuxBIOS at openbios.org

More information about the coreboot mailing list