[LinuxBIOS] EPIA M-II (CF Boot)

Carl Farrington linuxbios at compsup.demon.co.uk
Fri Dec 2 02:45:22 CET 2005

I can't get past initrd yet! VFS: Unable to mount root hde1 or unknown-block 
It seems that even though I'm starting up cardmgr in the initrd, which 
sucessfully finds hde and hde1, upon finishing the initrd (closing the shell 
or end of linuxrc), the kernel doesn't find hde1. Could this be to do with 
my 2.6 kernel not having devfs. I have fired up udevstart though, although 
I'm not 100% sure what I'm doing, the device nodes are being created.

Or could it be that I need to upgrade to pcmciautils - the new pcmcia-stuff, 
as the kernel is warning me about use of depreciated ioctls with cardmgr.

ho hum. I haven't bothered playing on it tonight, as I've been staying up 
'til ~4:30am on this lately and that's bad for my work!

----- Original Message ----- 
From: "Jun OKAJIMA" <okajima at digitalinfra.co.jp>
To: "Carl Farrington" <linuxbios at compsup.demon.co.uk>
Cc: <linuxbios at openbios.org>
Sent: Friday, December 02, 2005 1:33 AM
Subject: Re: [LinuxBIOS] EPIA M-II (CF Boot)

> Gooood! but you can run X? This is the key. And I can not yet.
>                   --- Okajima, Jun. Tokyo, Japan.
>>I would like to add my name to the list of people who have suceeded with 
>>The VGA BIOS offset given by Nick Barker was no good for my board (Model:
>>EPIA-Mii12000 LVDS), I had to use skip=786432 as suggested by Jun.
>>I am having problems with the kernel recognising the CF device as hde1
>>though. I am able to manually mount hde1 from a diagnostics shell within 
>>initrd after running cardmgr, so it is available, but once I exit the 
>>the kernel is saying it can't find hde1.
>>I'm not sure if Nick used devfs with his setup, but that's not available 
>>my 2.6.14 kernel. I have used mknod to create the device, and also tried
>>using udevstart but still have the same problem. I wonder if it's 
>>to do with me having all the pcmcia stuff compiled directly into the 
>>instead of as loadable modules? Unfortunately I'm quite rusty with Linux!
>>Anyway, I suppose this is a bit off topic. The LinuxBIOS seems to work
>>great, thank you, and big thanks to Nick for all your work on the EPIA M2.
>>Oh, by the way, I used Award's AWDFLASH to flash linuxbios.bin. Using the
>>undocumented /F option. Nick's HOWTO talked about a flash_and_burn utility
>>which wasn't in the tree, and the flashrom tool just wouldn't compile for 
>>for some reason. AWDFLASH worked, except for some strange quirks. I can't 
>>certain if it was due to bad floppies on my part, but for some reason I 
>>I was having better success overwriting a good bios, rather than re-trying
>>on a failed flash. The machine would go loopy sometimes. It all works now
>>LinuxBIOS mailing list
>>LinuxBIOS at openbios.org

More information about the coreboot mailing list