[coreboot-gerrit] Change in coreboot[master]: drivers/spi/flash: Move flash ops to spi_flash_ctrlr structure

Furquan Shaikh (Code Review) gerrit at coreboot.org
Thu May 18 05:12:08 CEST 2017


Furquan Shaikh has posted comments on this change. ( https://review.coreboot.org/19757 )

Change subject: drivers/spi/flash: Move flash ops to spi_flash_ctrlr structure
......................................................................


Patch Set 5:

(3 comments)

https://review.coreboot.org/#/c/19757/5/src/drivers/spi/spi_flash.c
File src/drivers/spi/spi_flash.c:

Line 392: 	if (flash->ctrlr->status)
> I take it status() wasn't always available? Yes, that indeed does look that
Yeah, status() isn't provided by every driver.


https://review.coreboot.org/#/c/19757/5/src/drivers/spi/winbond.c
File src/drivers/spi/winbond.c:

Line 187: const struct spi_flash_ctrlr spi_flash_ctrlr = {
> static const
Done


https://review.coreboot.org/#/c/19757/5/src/include/spi_flash.h
File src/include/spi_flash.h:

PS5, Line 37: spi_flash_ctrlr 
> The one issue is that the spi part drivers aren't really controllers. Howev
Yeah, even I did not like the _ctrlr since its not truly a controller. Does "spi_flash_ops" seem like a better name for this structure?


-- 
To view, visit https://review.coreboot.org/19757
To unsubscribe, visit https://review.coreboot.org/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: I550cc4556fc4b63ebc174a7e2fde42251fe56052
Gerrit-PatchSet: 5
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Owner: Furquan Shaikh <furquan at google.com>
Gerrit-Reviewer: Aaron Durbin <adurbin at chromium.org>
Gerrit-Reviewer: Duncan Laurie <dlaurie at chromium.org>
Gerrit-Reviewer: Furquan Shaikh <furquan at google.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply at coreboot.org>
Gerrit-HasComments: Yes



More information about the coreboot-gerrit mailing list