[coreboot-gerrit] Change in coreboot[master]: [WIP] drv/intel/gma/opregion: Add common init_idg_opregion()

Patrick Rudolph (Code Review) gerrit at coreboot.org
Wed Jul 12 18:51:05 CEST 2017


Patrick Rudolph has posted comments on this change. ( https://review.coreboot.org/20394 )

Change subject: [WIP] drv/intel/gma/opregion: Add common init_idg_opregion()
......................................................................


Patch Set 1:

(4 comments)

https://review.coreboot.org/#/c/20394/1/src/drivers/intel/gma/opregion.c
File src/drivers/intel/gma/opregion.c:

https://review.coreboot.org/#/c/20394/1/src/drivers/intel/gma/opregion.c@101
PS1, Line 101: init_igd_opregion(igd_opregion_t *opregion)
please use the naming scheme: intel_gma_init_igd_opregion.
This would make clear where the code resides and it prevents conflicts with existing implementations.


https://review.coreboot.org/#/c/20394/1/src/drivers/intel/gma/opregion.c@132
PS1, Line 132: 		optionrom_header_t *oprom = (optionrom_header_t *) pci_rom_probe(dev_find_slot(0, PCI_DEVFN(0x2,0)));
character line limit


https://review.coreboot.org/#/c/20394/1/src/drivers/intel/gma/opregion.c@153
PS1, Line 153: 	if (!vbt)
Always false, as vbt is set to &fake_vbt


https://review.coreboot.org/#/c/20394/1/src/drivers/intel/gma/opregion.c@168
PS1, Line 168: 			rdev_munmap(&vbt_rdev, vbt);
if (need_unmap) ...



-- 
To view, visit https://review.coreboot.org/20394
To unsubscribe, visit https://review.coreboot.org/settings

Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-MessageType: comment
Gerrit-Change-Id: I2378043a82bdf785df10a702afef1123662e04d9
Gerrit-Change-Number: 20394
Gerrit-PatchSet: 1
Gerrit-Owner: Matt DeVillier <matt.devillier at gmail.com>
Gerrit-Reviewer: Patrick Rudolph <siro at das-labor.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply at coreboot.org>
Gerrit-Comment-Date: Wed, 12 Jul 2017 16:51:05 +0000
Gerrit-HasComments: Yes
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.coreboot.org/pipermail/coreboot-gerrit/attachments/20170712/638d0939/attachment.html>


More information about the coreboot-gerrit mailing list