[coreboot-gerrit] Patch merged into coreboot/master: chromeos: Simplify fill_lb_gpios even further

gerrit at coreboot.org gerrit at coreboot.org
Tue Apr 5 00:50:59 CEST 2016


the following patch was just integrated into master:
commit c445b4fc773296be525123eb472ea27ac807339f
Author: Julius Werner <jwerner at chromium.org>
Date:   Thu Mar 31 17:27:05 2016 -0700

    chromeos: Simplify fill_lb_gpios even further
    
    A long time ago many Chrome OS boards had pages full of duplicated
    boilerplate code for the fill_lb_gpios() function, and we spent a lot of
    time bikeshedding a proper solution that passes a table of lb_gpio
    structs which can be concisely written with a static struct initializer
    in http://crosreview.com/234648. Unfortunately we never really finished
    that patch and in the mean time a different solution using the
    fill_lb_gpio() helper got standardized onto most boards.
    
    Still, that solution is not quite as clean and concise as the one we had
    already designed, and it also wasn't applied consistently to all recent
    boards (causing more boards with bad code to get added afterwards). This
    patch switches all boards newer than Link to the better solution and
    also adds some nicer debug output for the GPIOs while I'm there.
    
    If more boards need to be converted from fill_lb_gpio() to this model
    later (e.g. from a branch), it's quite easy to do with:
    s/fill_lb_gpio(gpio++,\n\?\s*\([^,]*\),\n\?\s*\([^,]*\),\n\?\s*\([^,]*\),\n\?\s*\([^,]*\));/\t{\1, \2, \4, \3},/
    
    Based on a patch by Furquan Shaikh <furquan at google.com>.
    
    BUG=None
    BRANCH=None
    TEST=Booted on Oak. Ran abuild -x.
    
    Change-Id: I449974d1c75c8ed187f5e10935495b2f03725811
    Signed-off-by: Julius Werner <jwerner at chromium.org>
    Reviewed-on: https://review.coreboot.org/14226
    Tested-by: build bot (Jenkins)
    Reviewed-by: David Hendricks <dhendrix at chromium.org>


See https://review.coreboot.org/14226 for details.

-gerrit



More information about the coreboot-gerrit mailing list