[coreboot-gerrit] Patch merged into coreboot/master: a7902ed chromeos: Reverse FMAP signature constant to avoid having it in .rodata

gerrit at coreboot.org gerrit at coreboot.org
Mon Apr 13 12:22:58 CEST 2015


the following patch was just integrated into master:
commit a7902edf56244d92e7529afc9391e8d49913914f
Author: Julius Werner <jwerner at chromium.org>
Date:   Wed Jan 14 13:12:10 2015 -0800

    chromeos: Reverse FMAP signature constant to avoid having it in .rodata
    
    Even though coreboot always hardcodes the FMAP offset, the same is not
    possible for all other tools that manipulate ROM images. Some need to
    manually find the FMAP by searching for it's magic number (ASCII
    "__FMAP__"). If we do something like 'memcmp(fmap_buffer, "__FMAP__",
    ...) in coreboot code, it has the unfortunate side effect that the
    compiler will output that very same magic number as a constant in the
    .rodata section to compare against. Other tools may mistake this for the
    "real" FMAP location and get confused.
    
    This patch reverses the constant defined in coreboot and changes the
    only use of it correspondingly. It is not impossible but extremely
    unlikely (at the current state of the art) that any compiler would be
    clever enough to understand this pattern and optimize it back to a
    straight memcmp() (GCC 4.9 definitely doesn't), so it should solve the
    problem at least for another few years/decades.
    
    BRANCH=veyron
    BUG=chromium:447051
    TEST=Made sure the new binaries actually contain "__PAMF__" in their
    .rodata. Booted Pinky. Independently corrupted both the first and the
    last byte of the FMAP signature with a hex editor and confirmed that
    signature check fails in both cases.
    
    Change-Id: I314b5e7e4d78352f409e73a3ed0e71d1b56fe774
    Signed-off-by: Stefan Reinauer <reinauer at chromium.org>
    Original-Commit-Id: 1359d2d4502eb34a043dffab35cf4a5b033ed65a
    Original-Change-Id: I725652ef2a77f7f99884b46498428c3d68cd0945
    Original-Signed-off-by: Julius Werner <jwerner at chromium.org>
    Original-Reviewed-on: https://chromium-review.googlesource.com/240723
    Original-Reviewed-by: Daisuke Nojiri <dnojiri at chromium.org>
    Original-Reviewed-by: David Hendricks <dhendrix at chromium.org>
    Reviewed-on: http://review.coreboot.org/9562
    Tested-by: build bot (Jenkins)
    Reviewed-by: Patrick Georgi <pgeorgi at google.com>


See http://review.coreboot.org/9562 for details.

-gerrit



More information about the coreboot-gerrit mailing list