[SeaBIOS] Librem 15v3 hangs at Booting from Hard Disk...

Philip C. pchampon at gmail.com
Tue May 15 04:09:32 CEST 2018

Hello biosers,

I managed to get some feedback from Kevin, on IRC, which was set debug to
I began the adventure, by taking advantage of a pureos script

I had to make a few modifications
    megadl '
    mv Intel\ CSME\ 11.0\ Firmware\ Repository\ Pack\ r50.rar
    comment out lines 226 and 227
    cd coreboot/flashrom && CFLAGS="-Wno-error=deprecated-declarations"
make; cd -
    update the librem15v3 coreboot config file, setting seabios debug from
-1 to 8
    comment out the attempt to check the sha256 of the coreboot (since
debug changes sha)
    the script created a coreboot rom file and claimed that it flashed the

However, when I rebooted, I didn't see any extra output on the screen and
it is still hung on the Booting from Hard disk... message

Any thoughts on how I can get the debug output?


On Wed, May 9, 2018 at 9:14 PM Philip C. <pchampon at gmail.com> wrote:

> Hello everyone!
> I've been having some issues with a laptop recently. My Librem 15v3 was
> bouncing along, until one day I ran into an apt-get upgrade issue. I
> attempted to fix the affected script by pointing it to the base directory
> busybox lived. The upgrade completed without any apparent issue.
> But, now no matter what I do, unattended boots hang on
> SeaBIOS (version rel-1.11.0-0-g63451fc)
> Booting from Hard Disk...
> _
> I have tried reinstalling the OS, using their live boot ISO. Each time, no
> matter which disk I configure (/dev/sda or /dev/nvme0n1), the install fails
> with the message
> Installation failed Failed to run update-initramfs on the target The exit
> code was 2
> I have upgraded coreboot, no joy. I have also tried manually running grub,
> from the installer, ie
>    1. mkdir /mnt/root
>    2. cryptsetup luksOpen /dev/sda3 root
>    3. mount /dev/mapper/root /mnt/root
>    4. mount /dev/sda1 /mnt/root/boot
>    5. grub-install --boot-directory=/mnt/root/boot /dev/sda
>    6. update-grub2
> The folks at purism/librem seem to be as confused as I am. Does anyone
> here have any insight into how I can fix this problem?
> Thanks!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.coreboot.org/pipermail/seabios/attachments/20180514/4914f8d3/attachment.html>

More information about the SeaBIOS mailing list