[SeaBIOS] [PATCH 3/4] block: Rename disk_op_s->drive_gf to drive_fl

Kevin O'Connor kevin at koconnor.net
Wed Sep 27 17:15:26 CEST 2017


On Wed, Sep 27, 2017 at 04:56:05PM +0200, Paolo Bonzini wrote:
> On 11/07/2017 18:50, Kevin O'Connor wrote:
> > Now that the drive_s struct does not need to be in the f-segment,
> > rename references to drive_gf in the generic drive code to drive_fl.
> > 
> > This is just variable renames - no code changes.
> > 
> > Signed-off-by: Kevin O'Connor <kevin at koconnor.net>
> 
> There are still quite a few:
> 
> src/block.c:fill_ata_edd(struct segoff_s edd, struct drive_s *drive_gf)
> src/block.c:        drive_gf, struct atadrive_s, drive);
> src/block.c:    if (GET_GLOBALFLAT(drive_gf->type) == DTYPE_ATA) {
> src/block.c:        u8 translation = GET_GLOBALFLAT(drive_gf->translation);
> src/block.c:        edd, drive_gf, SEGOFF(SEG_LOW, (u32)&DefaultDPTE).segoff

If the 'struct drive_s' was known to be allocated with malloc_fseg()
(and thus GET_GLOBALFLAT() is valid), then I tried to leave the
variable as drive_gf.  In the above, the ATA drives are still
allocated with malloc_fseg() so I didn't change them.

> src/block.h:int fill_edd(struct segoff_s edd, struct drive_s *drive_gf);

This one was an oversight - thanks.

-Kevin



More information about the SeaBIOS mailing list