[SeaBIOS] Chromebook doesn't boot BSD

Kevin O'Connor kevin at koconnor.net
Mon Feb 15 18:27:09 CET 2016

On Mon, Feb 15, 2016 at 05:16:06PM +0100, Ronny Schneider wrote:
> > Am 15.02.2016 um 15:40 schrieb edward wandasiewicz <0.w3ntd at gmail.com>:
> > On Sun, Feb 14, 2016 at 11:02 PM, Kevin O'Connor <kevin at koconnor.net> wrote:
> >> - it looks more like the various BSD kernels don't like the USB
> >> controller and/or USB drive on your machine.  Have you tried
> >> using a different type of USB drive for the install media?  It's
> >> also possible there's something in the ACPI tables that coreboot
> >> provides that is confusing the BSDs.
> I tried several usb-sticks and sd-cards. Every time the same result:
> it doesn’t work.  If i boot NetBSD without ACPI-support the screen
> turns black and stays this way until the machine is shut down.
> >> Your logs seem to indicate you also have an eMMC and an SD card.
> >> Have you tried placing the install media on an SD card instead of
> >> USB?
> That’s right. The main storage device of this Chromebook is an
> eMMC. Booting from SD card is working if it is a linux. BSD won’t
> start from. The same results as using an usb stick.
> >> Another thing you could do is launch the install media with the
> >> same verson of SeaBIOS on QEMU emulating an XHCI drive and SD
> >> drive - just to see if it's possible to reproduce outside of your
> >> particular machine.  See below.
> Using QEMU it is working flawlessly, wether the SeaBIOS version is
> 1.8, 1.9 or 1.9.1 (which i compiled myself).  So it really seems to
> be a problem with the BSDs.

So, if both XHCI and SD work on QEMU, then I don't have much of a
guess as to what the underlying problem is.  It's odd that two
independent hardware systems (xhci and sd) would both experience the
same failure to find the root drive.

As a long shot, you could compile seabios without CONFIG_SDCARD and
then deploy it on your chromebook - just to see if booting from usb
then works.  Similarly, you could try without CONFIG_USB_XHCI to see
if sd somehow then works.  I don't have much hope either would help

The other option would be to follow up with the various BSD developers
to see if you can extract more debug information to narrow down the
cause of the failure.


More information about the SeaBIOS mailing list