[SeaBIOS] [PATCH 0/5] Simplify 16bit/32bit trampoline code

Kevin O'Connor kevin at koconnor.net
Mon Sep 14 14:26:21 CET 2015


This series simplifies some of the existing trampoline code.

-Kevin


Kevin O'Connor (5):
  Unify smm/sloppy variants of call32_prep/post and call16_helper
  Rename Call32Data to Call16Data
  Unify inline assembler in variants of call16 functions
  Unify call32_sloppy() and call32()
  Use transition32_nmi_off from call32() and call16_back()

 src/romlayout.S |  10 +-
 src/stacks.c    | 282 +++++++++++++++++++++-----------------------------------
 2 files changed, 106 insertions(+), 186 deletions(-)

-- 
2.4.3




More information about the SeaBIOS mailing list